馃憠 C贸mo hacer que los viejos temas de WordPress sean compatibles con las nuevas versiones - IsItWP

驴La barra de administraci贸n de WordPress necesita un men煤 desplegable m谩s?

>

Entonces, quiere que sus viejos temas de WordPress sean compatibles con las versiones más recientes de WordPress. Con WordPress 3.0 a la vuelta de la esquina, la compatibilidad de los temas es algo que está en la mente de muchas personas. Es bastante simple: no hacer absolutamente nada.

He estado creando temas de WordPress desde que se lanzó WordPress 2.3, ¿y adivinen qué? Esos temas todavía funciona hoy y no hay nada que yo necesitar hacer para mantenerlos trabajando con las versiones más nuevas de WordPress.

  • Tendrán ellos funcionalidad de comentarios roscados (alrededor de 2.7)? No, probablemente todavía tengan comentarios de "nivel único".
  • ¿Lo usará? post_thumbnails manejar las miniaturas de publicaciones (alrededor de 2.9)? No, pero no todos los temas usan las miniaturas de publicaciones de todos modos.
  • Tendrán el nuevo menús de navegación, encabezado personalizado e imágenes de fondo presentado en el próximo WordPress 3.0? No, y tenga en cuenta que no todos los temas necesitarán imágenes de fondo o encabezado personalizadas.

La mayoría de estas características las consideraría opcionales. Con tal vez la excepción de los comentarios de subprocesos o el nuevo sistema de menú, muchos temas ni siquiera necesitarán o se diseñarán en torno a cosas como miniaturas de publicaciones personalizadas o imágenes de encabezado.

Entonces, por favor, deja de preocuparte si tu tema se va a romper cuando actualices WordPress. Sin ofender a mis amigos desarrolladores de complementos, pero el 99% de las veces WordPress se rompe con una actualización principal, es culpa de un complemento (y probablemente lo hizo debido a las prácticas sospechosas de codificación de complementos).

Si un tema tiene una función personalizada que entra en conflicto con una nueva función de WordPress, también podría suceder lo mismo con los temas, por lo que es posible. Este es probablemente el único "error" que he escuchado pasar con una nueva actualización del núcleo (y no todos los temas utilizan la función get_categories).

Sinceramente, Nunca he visto un tema romper por completoy probablemente nunca lo haga Me interesaría escuchar tus pensamientos en los comentarios, ¿qué opinas sobre hacer que los temas sean "compatibles" con las nuevas versiones? ¿Alguna vez has visto un tema roto debido a una nueva versión de WordPress?

Si desea que su tema de WordPress aproveche las nuevas funciones que estarán disponibles una vez que se publique WordPress 3.0, este artículo tiene buena información sobre la integración de fondos personalizados, encabezados, menús, entre otras cosas.

Ver el v铆deo: C贸mo Crear un Blog Gratis en Blogger

Like this post? Please share to your friends:
Deja un comentario

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: